Jump to content

[Inactive] Deploy my .war but the only i get is HTTP 404 – Not Found


Recommended Posts

After depoying my .war appwebagenda i always 404 - Not found error.

It seems to be unable to reach Login.jsp. I use a java filter file to redirect you to login if you arent logged for security.The url i use to test it is "http://abarqueror.heliohost.org/appwebagenda/ServletUsuarioLogin".Ive tried too "http://abarqueror.heliohost.org/appwebagenda/ but doesnt work.


I think my web.xml is correct.I attach this files if you want to see it. I use Maven to create the war file but i dont know what im doing wrong


Thanks in advance





Link to comment
Share on other sites

Try compiling the war with username_ in front of the filename (e.g. abarquer_warname.war) and deploying that. Our system renames them during deployment if they don't already have username_ in front, and this breaks a lot of war files.

Link to comment
Share on other sites

You're probably getting a 404 error because there's basically nothing in your .war

# ls -la
total 4
drwxr-x---.  4 nobody nobody   37 Nov 21 13:56 .
drwxr-xr--. 16 nobody nobody 4096 Nov 22 05:02 ..
drwxr-x---.  3 nobody nobody   57 Nov 21 13:56 META-INF
drwxr-x---.  4 nobody nobody   32 Nov 21 13:56 WEB-INF
Have you tested this on your home pc?
Link to comment
Share on other sites

You're right. I was making it wrong with Maven.


Now i did it directly with Eclipse and I've checked that the war file contains all the jsps that it didn't contain before. But i get  "ERR_TOO_MANY_REDIRECTS"  ERROR.


I've tried deleting the cookies but it dt work nevertheless it seems to redirect correctly to "http://abarqueror.heliohost.org/appwebagenda/ServletUsuarioLogin" as i coded in FilterSession.java but I can't get it to load login.jsp yet.I dont know whats wrong
Link to comment
Share on other sites

Is there supposed to be a directory called ServletUsuarioLogin?

# ls -la
total 8
drwxr-x---.  8 nobody nobody  121 Nov 23 21:36 .
drwxr-xr--. 17 nobody nobody 4096 Nov 23 21:36 ..
drwxr-x---.  2 nobody nobody   41 Nov 23 21:36 actividad
-rw-r-----.  1 nobody nobody   11 Nov  8 11:16 .gitignore
drwxr-x---.  3 nobody nobody   57 Nov 23 21:36 META-INF
drwxr-x---.  2 nobody nobody   24 Nov 23 21:36 parciales
drwxr-x---.  5 nobody nobody   38 Nov 23 21:36 resources
drwxr-x---.  2 nobody nobody   61 Nov 23 21:36 usuario
drwxr-x---.  4 nobody nobody   93 Nov 23 21:36 WEB-INF
Link to comment
Share on other sites

ServletUsuarioLogin is a servlet and can be found at WEB-INF\classes\com\enlawebdekaaf\app\servlet\


login.jsp is placed at usuario\ which is where ServletUsuarioLogin redirects if you are not logged in

Is the .war badly structured?


It could be caused by the fact that Eclipse placed glassfish-web.xml and jboss-web.xml files under WEB-INF/ but no tomcat-web.xml file? I assumed that defining web.xml would be enough.


Thank you very much for your interest i'm going crazy :D

Link to comment
Share on other sites

  • 4 weeks later...
This topic is now closed to further replies.
  • Create New...