Jump to content

Request: Free Auto Ssl Installation On My Domain


Recommended Posts

Go to https://ricky.heliohost.org:2083/frontend/paper_lantern/softaculous/index.live.php and click installations. Then locate the line of the installation you want to back up and click "backup". It's the second icon from the left.

Ok thanks, and how can I restore it in a different server?

P.S.: I'm backing up data from Tommy account (username: maicol07) to Ricky Account (username: maicol01).


Link to comment
Share on other sites

Download the backup from

on Tommy and then upload it to

on Ricky. Then go to https://ricky.heliohost.org:2083/frontend/paper_lantern/softaculous/index.live.php and in the top right corner there is an icon that looks like a piece of paper with a zipper. Click that and you should be able to restore your backup from that screen.
Link to comment
Share on other sites

What domain/install are you trying to transfer? I can try doing it for you.

I solved. Now the last thing and then I'll delete this account. If you could, can you install SSL on all my domains in the Tommy account?


Link to comment
Share on other sites

Ok, I already explained this once, but I obviously didn't explain it well enough. Here is the error:

8:10:20 AM WARN The domain “mkgamers.ml” failed domain control validation: The system failed to fetch the <abbr title="Domain Control Validation">DCV</abbr> file at “<a href="http://mkgamers.ml/84B7B689C89D20849E99168BC2AA2BE5.txt">http://mkgamers.ml/84B7B689C89D20849E99168BC2AA2BE5.txt</a>” because of an error: The system failed to send an <abbr title="Hypertext Transfer Protocol">HTTP</abbr> “GET” request to “http://mkgamers.ml/84B7B689C89D20849E99168BC2AA2BE5.txt” because of an error: Timed out while waiting for socket to become ready for reading .
What that means is the system created a file called 84B7B689C89D20849E99168BC2AA2BE5.txt and then tried to access it externally by going to mkgamers.ml/84B7B689C89D20849E99168BC2AA2BE5.txt and failed. Obviously, that file gets deleted again as soon as the check has finished, but to see what is happening let's create it again and try to access it.

root@tommy [/home/maicol07/public_html/mkgamers.ml]# echo "hello world!" > 84B7B689C89D20849E99168BC2AA2BE5.txt
Now, when we try to go to http://mkgamers.ml/84B7B689C89D20849E99168BC2AA2BE5.txt we get an error saying that the ssl certificate is invalid rather than displaying "hello world!".


Now if we take a look at your .htaccess we see:

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv$
RewriteCond %{REQUEST_URI} !^/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
Nice, there is a rule for /<random 32 characters>.txt, but it's not going to work for the addon domain so we need to add a line to prevent it from forcing https on mkgamers.ml. So add this line

RewriteCond %{REQUEST_URI} !^/mkgamers\.ml/[A-F0-9]{32}\.txt(?:\ Comodo\ DCV)?$
Now, there is an exception for mkgamers.ml/84B7B689C89D20849E99168BC2AA2BE5.txt so it doesn't force https if someone requests it. Check it in the browser and instead of an ssl certificate error we see "hello world!" Each time you create an addon domain or any kind of domain for that matter test it out to make sure those text files can be read without any errors, and autossl will work. If you have any .htaccess rules preventing it from being accessed then ssl won't automatically get installed on that domain.


Does that explain it a little better?

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...