Jump to content

403 Error On Simple Page Load


Recommended Posts

Hi guys,


My website was working this morning, but now I am getting a 403 even when I load an empty index.html in the public_html root, or anything else: http://amirba.heliohost.org/


user: amirba

domain: amirba.heliohost.org

server: stevie


It may have been my fault because I did the following recently:

* I did a little cleaning, deleted some folders including some of the _vti_ folders

* deleted some unused databases

* was playing around in the cgi screen

* tried to install a drupal which didn't work.

* very recently had a inactivity suspension, but It had worked after unsuspending.




Link to comment
Share on other sites

Check for a .htaccess file in public_html (use FTP or be sure to show hidden files in the cPanel file manager). Delete or rename it if you find it. Drupal creates one in the folder where you install it I think. (The reason Drupal didn't work is probably Stevie's database server being broken at the moment).


Make sure that public_html has the right permissions. I believe the correct permissions are 750 (that's what mine is).


The _vti_ stuff is frontpage extensions. There's a page for them in cPanel (it's at the bottom under the advanced group I believe). Go there and select to uninstall them. All of the _vti_ stuff and anything related will get fully removed when you do.


Dropping old databases won't cause a 403 error.


I'm not familiar with the CGI screen, so that might be another issue.

Link to comment
Share on other sites

Thanks guys,


I can't delete .htaccess as it keeps coming back. but it's empty now.

I set the permissions for public_html, public_html/.htaccess and public_html/index.html to 777. But still getting a 403. The exact error is this:

You don't have permission to access /index.html on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request. Apache/2.2.16 (Unix) mod_ssl/2.2.16 OpenSSL/0.9.8e-fips-rhel5 FrontPage/ mod_bwlimited/1.4 mod_auth_passthrough/2.1 mod_wsgi/3.3 Python/2.7.1 Server at amirbakhtiary.info Port 80

Link to comment
Share on other sites

This should be fixed now. :)


This was due to incorrect permissions being set on your home directory (/home1/amirba). Your home directory was set to privileges 0744, when it should have been set to 0711.


I've also reset the files you changed to 0777 back to normal. :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...